Internet Outage
Incident Report for Wentworth Institute of Technology
Resolved
Internet Service has been restored. Engineers continue to work with our vendor to verify and further examine the environment.

Thank you for your patience while we worked to restore normal service. If you are continuing to experience an issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted about 1 month ago. Apr 12, 2019 - 09:01 EDT
Identified
Engineers have acknowledged a service interruption for Campus Internet.
We are currently working with our Internet vendors to restore service and updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted about 1 month ago. Apr 12, 2019 - 08:41 EDT
This incident affected: Internet and Network Access.