Library Plotter Release Station
Incident Report for Wentworth Institute of Technology
Resolved
the library plotter release station has been repaired and put back into place.
Posted 6 months ago. Mar 01, 2019 - 15:11 EST
Identified
The release station for the library printer is currently not functional. Users can still print to the plotter but jobs will come out direct.
Posted 6 months ago. Feb 22, 2019 - 15:28 EST
This incident affected: Printing, Plotting, & Scanning.