Blackboard Login Not Working
Incident Report for Wentworth Institute of Technology
Resolved
This issue has been fully resolved at this time.

Thank you for your patience while we worked to restore normal service. If you are continuing to experience an issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted 7 months ago. Feb 01, 2019 - 09:30 EST
Identified
Blackboard has acknowledged that maintenance overnight is causing the issue. They are currently working to restore service and updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted 7 months ago. Feb 01, 2019 - 08:15 EST
Investigating
We are investigating reports of users unable to login to Blackboard. Updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted 7 months ago. Feb 01, 2019 - 08:01 EST
This incident affected: Digital Learning Environment.