Plotter in Douglas D. Schumann Library & Learning Commons is Unavailable
Incident Report for Wentworth Institute of Technology
Resolved
The plotter in the Douglas D. Schumann Library and Learning Commons is now operational. Thank you for your patience while this unit was being serviced.
Posted 6 months ago. Dec 05, 2018 - 13:57 EST
Update
A technician has been on site today and we expect the plotter will be in service this afternoon.
Posted 6 months ago. Dec 05, 2018 - 12:39 EST
Identified
The plotter in the library is currently out of commission due to a mechanical issue, and should be repaired by the end of the day tomorrow (12/4). If you need to print on a plotter, please head to the Architecture studio located in Annex North.
Posted 7 months ago. Dec 03, 2018 - 10:18 EST
This incident affected: Printing, Plotting, & Scanning.