LConnect Service Interruption
Incident Report for Wentworth Institute of Technology
Resolved
Access to LConnect has been restored.

If you are still experiencing any issues, please contact the Tech Spot at 617.989.4500 or helpdesk@wit.edu.
Posted 7 months ago. Mar 12, 2018 - 09:19 EDT
Update
If you are trying to access information in LeopardWeb (course schedule, bill payment, advising, etc.) you can still get there by starting at http://leopardweb.wit.edu which bypasses LConnect.
Posted 7 months ago. Mar 12, 2018 - 08:53 EDT
Investigating
We are currently investigating reports of a service interruption to LConnect

Updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or helpdesk@wit.edu.
Posted 7 months ago. Mar 12, 2018 - 08:38 EDT