Apple Software Issue
Incident Report for Wentworth Institute of Technology
Resolved
Apple Self Service is fully functional at this time. Please let the Tech Spot know if you have any issues.
Posted 5 months ago. May 09, 2018 - 11:43 EDT
Identified
We are currently having an issue with Self Service on Apple devices making software undeliverable. The issue is being worked on and should be resolved by this evening. We appreciate your patience while we resolve this.
Posted 5 months ago. May 08, 2018 - 16:18 EDT
This incident affected: Software Download & Licensing.