555 Laundry not accepting Fenway Cash
Incident Report for Wentworth Institute of Technology
Resolved
This incident has been resolved.
Posted 19 days ago. Sep 07, 2018 - 07:55 EDT
Identified
We are aware of a service interruption involving Fenway Cash and the Laundry View website in 555 Huntington and are working with the vendor and campus resources to get it repaired. Updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted 23 days ago. Sep 03, 2018 - 14:36 EDT