E-Bill Service Outage due to CashNet unscheduled outage
Incident Report for Wentworth Institute of Technology
Resolved
This issue has been fully resolved at this time.

If you are continuing to experience the issue or need further assistance, please contact the Tech Spot at 617.989.4500 or helpdesk@wit.edu. Thank you for your patience while we worked to restore normal service.
Posted 2 months ago. Jul 19, 2017 - 14:54 EDT
Identified
E-Bill is currently unavailable due to an unscheduled outage of the CashNet service. The third-party has acknowledged this issue and is investigating.

We are currently working to restore service and updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or helpdesk@wit.edu.
Posted 2 months ago. Jul 19, 2017 - 13:16 EDT