Wireless connection failures on Windows 8 devices
Incident Report for Wentworth Institute of Technology
Resolved
After a second day, we have seen a low volume of devices experiencing this issue. If you have a device which is not connecting to the wireless network properly, please review the directions at https://wit.edu/wireless and contact the Help Desk for further assistance if required. Thank you!
Posted 7 months ago. May 09, 2017 - 16:45 EDT
Update
The issue has been confirmed on other model laptops including T440p and W541 when running Windows 8/8.1. On these models, updating to the current WiFi driver resolves the issue. We are developing step by step directions to complete this and will share as soon as available or you can visit the Help Desk for assistance. Advanced users may wish to attempt to update through device manager on their own.

For W530 models, updating the drivers does not resolve the problem. On this model, we are currently updating to Windows 10 as a resolution. If you prefer not to do that, waiting for further updates while using a wired connection is your best option.
Posted 7 months ago. May 08, 2017 - 15:07 EDT
Investigating
We are currently investigating a large number of people reporting devices with Windows 8 or 8.1 which cannot connect to wireless networks. We do not believe this problem is specific to Wentworth's wireless network and is most prevelent with the Lenovo W530 model.

One option as a "quick fix" is to be re-imaged to Windows 10 which does not appear to suffer the same problems. Technicians are working on determining the root cause and will update as soon as possible.
Posted 7 months ago. May 08, 2017 - 11:18 EDT