Banner Service Interruption
Incident Report for Wentworth Institute of Technology
Resolved
Access to Banner has been restored. DTS is continuing to investigate the cause of this service interruption.
Posted 7 months ago. Mar 09, 2018 - 08:35 EST
Investigating
We are currently investigating reports of a service interruption to Banner.

Updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or helpdesk@wit.edu.
Posted 7 months ago. Mar 09, 2018 - 07:47 EST