Blogs.wit.edu is currently unavailable
Incident Report for Wentworth Institute of Technology
Resolved
The issue with blogs.wit.edu has been resolved.
If you are continuing to experience the issue or need further assistance, please contact the Tech Spot at 617.989.4500 or helpdesk@wit.edu.
Posted about 2 months ago. Jul 28, 2017 - 15:13 EDT
Identified
Wentworth related blogs hosted on the blogs.wit.edu site are currently unavailable. DTS is aware of this issue and actively working to resolve it.
Posted 2 months ago. Jul 27, 2017 - 14:27 EDT