Printing Service Interruption
Incident Report for Wentworth Institute of Technology
Resolved
This issue has been fully resolved at this time.

If you are continuing to experience the issue or need further assistance, please contact the Tech Spot at 617.989.4500 or helpdesk@wit.edu. Thank you for your patience while we worked to restore normal service.
Posted 3 months ago. Apr 16, 2018 - 15:12 EDT
Monitoring
At this time service may be available. Engineers are continuing to monitor the service and we will confirm once it has been fully tested.

If you are continuing to experience the issue or need further assistance, please contact the Tech Spot at 617.989.4500 or helpdesk@wit.edu. Thank you for your patience while we worked to restore normal service.
Posted 3 months ago. Apr 16, 2018 - 14:20 EDT
Investigating
We are investigating reports of a Printing Service Interruption. Updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or helpdesk@wit.edu.
Posted 3 months ago. Apr 16, 2018 - 14:14 EDT