Banner Service Interruption
Incident Report for Wentworth Institute of Technology
Resolved
The service interruption to Banner has been resolved.

If you are still experiencing an issue or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted 21 days ago. Jun 29, 2018 - 20:30 EDT
Investigating
We are currently investigating reports of a service interruption to Banner.

Updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted 21 days ago. Jun 29, 2018 - 17:17 EDT
This incident affected: Student Information System.