LConnect Unavailable
Incident Report for Wentworth Institute of Technology
Resolved
LConnect service has been restored at this time.

If you are continuing to experience the issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu. Thank you for your patience while we worked to restore normal service.
Posted 7 days ago. Aug 08, 2018 - 15:00 EDT
Update
LeopardWeb is available again, and we actively working to resolved the LConnect issue.
Posted 7 days ago. Aug 08, 2018 - 09:59 EDT
Update
LeopardWeb is now unavailable at this time. We are working to restore service.
Posted 7 days ago. Aug 08, 2018 - 09:46 EDT
Update
As a reminder, billing and registration services can be accessed directly through LeopardWeb at https://leopardweb.wit.edu and remain available.
Posted 7 days ago. Aug 08, 2018 - 09:15 EDT
Investigating
LConnect is currently unavailable. We are investigating this issue and updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted 7 days ago. Aug 08, 2018 - 08:10 EDT
This incident affected: Student Information System.