Campus Network Outage
Incident Report for Wentworth Institute of Technology
Resolved
This incident has been resolved.
Posted 5 days ago. Aug 10, 2018 - 12:15 EDT
Monitoring
Earlier today there was a campus network outage. A blown fuse triggered a fire alarm, and the networking equipment was shut down in an abundance of caution. This has now been resolved.

If you are continuing to experience the issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted 5 days ago. Aug 10, 2018 - 11:53 EDT
This incident affected: Internet and Network Access.