LConnect Unavailable
Incident Report for Wentworth Institute of Technology
Resolved
LConnect is available again. Thank you for your patience.
Posted 3 months ago. Jul 21, 2018 - 17:01 EDT
Identified
Engineers have acknowledged a service interruption for LConnect. Billing and registration services remain available through LeopardWeb at https://leopardweb.wit.edu

We are currently working to restore service and updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted 3 months ago. Jul 21, 2018 - 14:35 EDT
This incident affected: Student Information System.