Skype for Business Issue
Incident Report for Wentworth Institute of Technology
Resolved
The Skype for Business issue has been resolved.
Posted 5 months ago. Feb 22, 2018 - 09:11 EST
Investigating
DTS is currently investigating an issue with logging into Skype for Business. This is also having some impact on phones. We will provide an update as soon as we have more information.
Posted 5 months ago. Feb 22, 2018 - 08:09 EST