ACKNOWLEDGED - PaperCut & Follow Me Printing Disruption
Incident Report for Wentworth Institute of Technology
Resolved
Follow Me Printing & PaperCut are now fully resolved at this time.

If you are continuing to experience the issue or need further assistance, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu. Thank you for your patience while we worked to restore normal service.
Posted 27 days ago. Aug 30, 2018 - 13:20 EDT
Identified
Engineers have acknowledged a service interruption for Follow Me Printing & PaperCut.

We are currently working to restore service and updates will be posted as they become available.

If you are experiencing different symptoms or wish to report another problem, please contact the Tech Spot at 617.989.4500 or techspot@wit.edu.
Posted 27 days ago. Aug 30, 2018 - 12:32 EDT
This incident affected: Printing, Plotting, & Scanning.